Back to overview
Downtime

Platform downtime

Aug 13 at 02:04pm BST
Affected services
App
Browser Cluster

Resolved
Aug 16 at 03:14pm BST

Services have been restored by our supplier

Created
Aug 13 at 02:04pm BST

We are experiencing downtime from our supplier